Dscp là gì

  -  

Tổng vừa lòng Dscp Là Gì – Cho Hỏi vài điều Về Dscp là chủ đề vào nội dung bài viết hiện thời của Hùng Bá Tam Quốc. Đọc ngôn từ để biết đầy đủ nhé.

Bạn đang xem: Dscp là gì


Đôi khi, hệ thống mạng hoạt động trên cửa hàng phân pân hận tốt nhất có thể, có nghĩa là toàn bộ gói tin ở mạng đều phải sở hữu mức độ ưu tiên ngang bằng cùng gồm thời cơ được chuyển mang đến đích một cách kịp lúc. lúc tắc nghẽn xẩy ra, toàn bộ những gói tin đa số có khả năng bị ùn tắc. Nếu không có QoS, Switch đã cung ứng dịch vụ tốt nhất có thể cho toàn bộ những gói, bất kể câu chữ gói tốt size. Nó đang gửi các gói tin cơ mà không tồn tại bất kỳ sự đảm bảo về độ tin yêu, giới hạn độ trễ hoặc thông lượng như thế nào.

Quý khách hàng vẫn xem: Dscp là gì

Lúc ta áp dụng hào kiệt QoS, ta hoàn toàn có thể chọn 1 dạng gói tin ví dụ, ưu tiên nó theo tầm đặc biệt tương đối của chính nó cùng thực hiện nghệ thuật quản lý ùn tắc và nên tránh ùn tắc nhằm cung cấp ưu tiên. Việc tiến hành QoS vào mạng khiến cho hiệu năng mạng dễ dàng dự đoán hơn và thực hiện băng thông công dụng hơn.

II. Cơ chế hoạt động

-Việc tiến hành QoS được dựa trên con kiến ​​trúc dịch vụ phân minh (Diff-Serv), phong cách xây dựng này hướng dẫn và chỉ định rằng mỗi gói tin được phân các loại Lúc nhập vào mạng. Các gói tin sẽ tiến hành đánh dấu như Class of Service (CoS), DSCP, IP Precedence… Nên ghi lại gói tin càng cấp tốc càng xuất sắc, lúc được ưu tiên sớm thì luồng đi qua sản phẩm công nghệ tiếp sau sẽ suôn sẻ tru.

1, Giá trị IP. Precedence và DSCP. (Differentiated Service Code Point)

Layer 3

IPhường Precedence với DSCP là nhị trường được áp dụng nhiều duy nhất nhằm khắc ghi. Các phương tiện QoS thực hiện chúng cũng chính vì header của gói tin IP vĩnh cửu ở rất nhiều khu vực trên mạng.Trong IP. header của từng gói tin bao gồm đựng một ngôi trường hotline là ToS (Type of Service). Trường Type of Service có mức giá trị 1 byte. Và 3 bits trước tiên (P2 cho P0) dùng làm chế độ những quý giá ghi lại độ ưu tiên của packet với những quý giá này được gọi là IP Precedence.


*

IPhường Precedence hoặc DSCP


*

Cấu trúc trường Type of Service

Giá trị IP precedence ở trong vòng từ 0 đến 7.

Tại sao lại có những khoảng chừng giá trị bên trên, rõ ràng như sau:

3 bits trước tiên (P2 đến P0): IPhường Precedence. Do thực hiện 3 bits buộc phải sẽ có được 8 quý hiếm (000 cho 111) định ra độ ưu tiên của gói tin tự phải chăng đến cao. Giúp router giải pháp xử lý các gói tin này theo chất lượng hình thức dịch vụ. ví dụ như, gói tin được đánh dấu với mức giá trị IPhường Precedence là 7 (111) sẽ có độ ưu tiên về bandwidth, được thoát khỏi sản phẩm ngóng trước… rộng so với các gói tin được khắc ghi với mức giá trị IPhường Precedence là 3 (011).

3 bits tiếp theo sau (T2 mang đến T0):

bit T2 (T2=1): Yêu cầu truyền vội. bit T1 (T1=1): Yêu cầu truyền cùng với đường truyền rất chất lượng. bit T0 (T0=1): Yêu cầu truyền đảm bảo an toàn.

2 bit cuối (CU1-CU2): Không sử dụng tới (Currently and Unused).

Tuy nhiên, bây chừ không sử dụng các cực hiếm của IP Precedence để đánh dấu gói tin. Với mục tiêu làm cho tăng hiệu quả quality hình thức thì các cơ chế QoS đã dùng các cực hiếm được hotline là điểm mã hình thức tách biệt DSCPhường (Differentiated Service Code Point) nhằm tiến hành đánh dấu gói tin. 3 bits IP Precedence đang kết hợp với 3 bits tiếp theo (trường đoản cú T2 cho T0) tạo ra thành 6 bits diễn tả các giá trị của DSCP. Do kia các quý hiếm DSCP.. nằm trong vòng tự 0 mang đến 63.

Các bits này được ánh xạ nlỗi sau:


*

Giá trị IP.. Precedence rất có thể được ánh xạ đến ngôi trường DSCP

6 bits DiffServ (DS) từ bỏ DS5 cho DS0 được dùng làm khắc ghi gói tin cùng chỉ ra rằng phương thức mỗi router cách xử lý gói tin như thế nào. Với 6 bits hoàn toàn có thể tạo ra cho 64 class hình thức dịch vụ.


*

IP Header trước cùng sau khắc ghi DSCP

Lựa lựa chọn cực hiếm DSCPhường đề xuất tương thích cùng với máy tự IPhường Precedence. Nói cách khác là nên so trùng khớp quý hiếm của 3 bits trước tiên. Mọi sự đổi khác phần đa nên chăm chú đến sự trùng khớp này.Ví dụ: quý giá IP. Precedence là 5 (101) thì quý hiếm DSCP có thể là 101 000.


*

Có những hình dáng chuyến qua gói tin trong DSCP là AF (assured forwarding: bảo đảm đẩy gói) cùng EF (expedited forwarding: xúc tiến đẩy gói), lựa chọn lớp (Class Selector) cùng khoác định (Default).


Ánh xạ giữa PHB cùng DSCP

Với EF: độ trễ, độ dịch chuyển trễ, tỉ trọng mất gói thấp, đường dẫn được bảo đảm, cùng các dịch vụ sau cuối đề nghị thông qua miền DiffServ. EF được sử dụng mang đến hầu hết luồng tất cả độ ưu tiên không nhỏ.

Với AF: định rõ hồ hết hình thức dịch vụ khác nhau sẽ tiến hành bảo đảm chuyển tiếp, trải qua miền DiffServ. AF được chia thành 4 lớp (class) đảm bảo an toàn đẩy gói khác nhau với 3 cường độ ưu tiên thải trừ gói (drop precedence) xác định khác nhau. AFxy, x (chỉ số lớp) càng tốt thì xếp vào sản phẩm ngóng xuất sắc hơn, x càng bé dại thì càng dễ bị loại vứt, y càng tốt thì gói tin càng dễ bị nockout bỏ. Vậy AF4một là gói tin được ưu tiên tốt nhất, mang đến AF42, AF43,… AF13 dễ dàng bị loại quăng quật nhất


2, Gía trị cos (class of service) Layer 2

Cos: Class of service: Các lớp hình thức (0 mang đến 7)

Trường CoS chỉ trường thọ bên trong Etheframe khi các con đường trunk 802.1Q với ISL được thực hiện. cũng có thể thực hiện ngôi trường này để thiết lập 8 cực hiếm nhị phân khác nhau nhưng có thể dùng đến công dụng phân loại của pháp luật QoS nhỏng IPhường Precedence cùng DSCP.. Giá trị Cos càng tốt thì gói tin frame càng được ưu tiên.


Cos 7: Không thực hiện (reserved)

Cos 6: Không sử dụng (reserved)

Cos 5: Dữ liệu voice (voice bearer)

Cos 4: Dữ liệu video conferencing

Cos 3: Call signalling

Cos 2: High priority data

Cos 1: Medium priority data

Cos 0: best effort data


Hình 2: Ví dụ rõ ràng về gán giá trị CoS với DSCP

Theo hình 2, minch hoạ một LAN switch thực hiện tác dụng QoS dựa vào CoS. R3 phát âm các frame đi vào trên một cổng (ví dụ F0/9), khắc ghi cực hiếm DSCP. dựa trên những thông số kỹ thuật CoS. Thêm vào kia R3 gọi các quý giá DSCP. cho các gói tin đã rời khỏi cổng F0/0 về SW2, gán cực hiếm trong 802.1Q header. Giá trị đích thực bên trên cổng F0/0 của R3 đến quy trình phân loại và đánh dấu nlỗi sau: Các frame bước vào với mức giá trị CoS 5 sẽ tiến hành gán quý hiếm DSCP EF (mức ưu tiên phệ nhất) Các frame lấn sân vào với cái giá trị CoS 1 sẽ tiến hành gán quý giá AF11.

3, Mô hình Qos


Phân nhiều loại (classification): Phân một số loại một gói tin bằng cách links nó với nhãn QoS. Sở biến hóa ánh xạ CoS hoặc DSCP vào gói cho tới nhãn QoS nhằm rành mạch một loại lưu lượng truy vấn với 1 loại khác. Kiểm tra gói và khẳng định nhãn qos dựa vào ACL hoặc cấu hình.

Chính sách cùng lưu lại (policing and marking):

Sau Lúc gói được phân các loại cùng gồm nhãn QoS dựa vào DSCP hoặc dựa vào CoS được gán cho nó.

Policing tương quan tới việc tạo thành một policer xác minh giới hạn đường dẫn cho lưu lượt truy cập. Các gói thừa vượt số lượng giới hạn nằm bên cạnh thông số kỹ thuật hoặc không tương xứng. Mỗi policer đưa ra quyết định trên các đại lý packet-by-packet mặc dầu gói tin phù hợp hay là không cân xứng và hướng đẫn những hành vi bên trên gói. Những hành vi này, được thực hiện vì marker, bao gồm đi qua gói tin nhưng ko sửa đổi, vứt gói tin, hoặc sửa đổi (ghi lại xuống) DSCP được chỉ định của gói và chất nhận được gói đi qua.

Hàng chờ (queue):

Hàng hóng đánh giá nhãn QoS và quý hiếm DSCP.. hoặc CoS tương xứng nhằm chọn thành nhị mặt hàng đợi nhtràn lên để đặt gói tin. Xếp hàng được bức tốc cùng với thuật tân oán weighted tail drop (WTD), một phương pháp tách tắc nghẽn. Nếu thừa quá ngưỡng, gói tin đã bị nockout vứt.

Lập planer hình thức dịch vụ các mặt hàng đợi dựa vào shaped round robin (SRR) được định thông số kỹ thuật của bọn chúng. Một trong các mặt hàng chờ đột nhập là hàng đợi ưu tiên, cùng SRR các dịch vụ nó mang đến chia sẻ được thông số kỹ thuật của nó trước lúc giao hàng sản phẩm hóng khác

4. Cấu hình Standard Qos bên trên Switch layer 3

Khởi tạo thành Qos bên trên switch 3750 catalyst (khoác định disable)

Sw(config) mls qos no mls qos

Show mls qos

Khởi chế tạo ra qos dựa vào vlan

Int g0/0

Sw(config) mls qos vlan-based no mls qos vlan-based

Show mls qos int g0/0

Cấu hình qos trên các cổng tin cậy (mặc địch thiếu tín nhiệm cậy)

Sw(config) int g0/0

Mls qos trust no mls qos trust int g0/0

Cấu hình cực hiếm cos, dscp, ip pre mang đến gói tin thông số kỹ thuật class-map:

Câu lệnh class-map: dùng làm phân loại lưu lượng tài liệu theo nhu cầu của người sử dụng, có thể sử dụng kết hợp với những mức sử dụng phân một số loại nhỏng ACL tốt sử dụng chính sách NBAR.Câu lệnh policy-map: dùng để làm lý lẽ giải pháp hành xử đến từng các loại giữ lượng đã có được phân một số loại, bí quyết hành xử hoàn toàn có thể đơn giản là phân nhiều loại tài liệu, hoàn toàn có thể là khắc ghi hay được sử dụng trong các chế độ QoS không giống, để ý là luôn tồn ở 1 một số loại cấu hình class-maps thương hiệu là class-mặc định nhằm mục tiêu phân một số loại tất cả các lưu lại lượng chưa được phân các loại vị phần đa class-bản đồ trước.

SW (config) # class-mapname

SW (config-cmap) # match access-group Name access-list-name

SW (config-cmap) # match coscos-value

SW (config-cmap) # match dscpdscp-value-1

SW (config-cmap) # match ip precedenceip-precedence-value-1

Hoặc

SW (config)#policy-mapname

SW (config-pmap)#classname

SW (config-pmap-c)#mix ip precedenceip-precedence-value-1

SW (config-pmap-c)#phối dscpdscp-value-1

SW (config-pmap-c)#set cos cos-value

Ta có:

SW (config-cmap) # class-maps (match-any | match-all)name

SW (config-cmap) # match access-group name test

SW (config-cmap) # match int f0/1

Mặc định là đã match-all, là vừa lòng cả toàn bộ điều kiện. Nếu là match-any, chỉ việc 1 trong vô số nhiều điều kiện.


Ví dụ: Cấu hình trên SWC làm sao cho PC0, PC1 lượng traffic mail được ưu tiên rộng với website, cùng traffic còn sót lại của hệ thống local

Cách 1: Tạo 2 access danh mục mail (pop3) vs web (http https)

SWC(config)#ip access-danh sách extendedmail

SWC(config-ext-nacl)#permit tcp any host 2.2.2.2 eq 110

SWC(config-ext-nacl)#ex

SWC(config)#ip access-danh mục extendedweb

SWC(config-ext-nacl)#permit tcp any host 2.2.2.2 eq 80

SWC(config-ext-nacl)#permit tcp any host 2.2.2.2 eq 443

Cách 2: Tạo 2 class map tương xứng cùng với access-list

SWC(config)#class-mapmail

SWC(config-cmap)#match access-group namemail

SWC(config-cmap)#ex

SWC(config)#class-mapweb

SWCconfig-cmap)#match access-group nameweb

SWC(config-cmap)#ex

Cách 3: Tạo policy bản đồ cùng gán giá trị ip precedence, class-mặc định là lượng traffic còn sót lại.

SWC(config)#policy-mapabc

SWC(config-pmap)#classmail

SWC(config-pmap-c)#set ip precedence 3

SWC(config-pmap-c)#ex

SWC(config-pmap)#classweb

SWC(config-pmap-c)#mix ip precedence 2

SWC(config-pmap-c)#ex

SWC(config-pmap)#class class-default

SWC(config-pmap-c)#phối ip precedence 1

SWC(config-pmap-c)#end

Cách 4: Gán policy-maps vào cổng

SWC(config)#int range f0/1-2

SWC(config)# service-policy inputabc

Vậy ở đây bọn họ vẫn ưu tiên các gói tin theo mail với giá trị ip predence cao hơn bắt buộc đi trước, do đó đã truy cập nhanh khô hơn so với website cùng luồng tin sót lại.

Xem thêm: Thế Nào Là Iphone Trôi Bảo Hành Là Gì ? Có Nên Mua Iphone Trôi Bảo Hành?

Gán quý giá cos-to-dscp: quý khách áp dụng CoS-to-DSCP.. nhằm ánh xạ các giá trị CoS trong các gói tài liệu mang lại một giá trị DSCP mà lại QoS thực hiện vào nội cỗ nhằm biểu lộ mức độ ưu tiên của lưu giữ lượt truy cập.

SW1(config)#mls qos bản đồ ?

cos-dscp cos-dscp map: eight dscp values for cos 0-7

SW1(config)#mls qos maps cos-dscp 0 8 16 24 32 46 48 56

SW1(config)#exit

SW1#show mls qos maps cos-dscp

Cos-dscp map: cos: 0 1 2 3 4 5 6 7

dscp: 0 8 16 24 32 46 48 56

Vậy toàn bộ quý giá cos từ bỏ 0 mang đến 7 được gán quý giá DSCPhường theo máy tự: 0, 8, 16, 24, 32, 46, 48, 56

Ánh xạ quý giá dcsp-to-dscp mutation map: Nếu nhị miền QoS gồm DSCP. không giống nhau, hãy áp dụng DSCP-to-DSCP mutation bản đồ nhằm dịch một cỗ quý hiếm DSCPhường. để tương xứng với có mang của miền khác.

Giá trị DSCP mới vẫn ghi đè lên trên một gói trong gói và QoS cách xử lý gói với giá trị bắt đầu này. Công tắc sẽ gửi gói tin ra khỏi cổng với giá trị DSCPhường bắt đầu.

Quý khách hàng rất có thể cấu hình những DSCP-to-DSCP mutation maps bên trên cổng vào.


SW1(config)#mls qos maps dscp-mutationDEMO24 26 28 30 to 24

SW1(config)#interface gig 1/0/8

SW1(config-if)#mls qos trust dscp

SW1(config-if)#mls qos dscp-mutation

DEMO SW1(config-if)#do show mls qos maps dscp-mutation

Dscp-dscp mutation map:


Các quý hiếm dscp 24 26 28 30 đang ánh xạ thành 24

5. Cấu hình qos bằng policy bản đồ và class map

Cấu hình với 1 luồng đường đi

Bước 1: Tạo class-map kết hợp với access-menu, chúng ta cũng có thể dùng access-danh mục theo từng host PC, hoặc theo từng hình thức dịch vụ như website, mail.

Switch(config)# access-các mục 1 permit 10.1.0.0 0.0.0.255

Bước 2: Tạo policy-bản đồ kết hợp với class-bản đồ làm việc trên, tiếp đến cấu hình nhằm tăng bớt đường truyền, 1000000: Băng thông giới hạn bps, 8000: Tốc độ burst Bytes

Switch(config)# class-mapipclass1

Switch(config-cmap)# match access-group 1

Switch(config-cmap)# exit

Switch(config)# policy-mapflow1t

Switch(config-pmap)# classipclass1

Switch(config-pmap-c)# trust dscp

Switch(config-pmap-c)# police 1000000 8000 exceed-action policed-dscp-transmit

Switch(config-pmap-c)# exit

Switch(config-pmap)# exit

+ Cách 3: Cấu hình gán các dịch vụ policy vào cổng đồ dùng lí, đầu vào hoặc output

Switch(config)# interface gigabitetheg0/0

Switch(config-if)# service-policy inputflow1t

Tại phía trên bọn họ có hình thông số kỹ thuật qos bên trên SW 3560 để tăng sút đường truyền cho vùng mạng Lan, mặc dù tùy thuộc vào lượng đường truyền nhưng ISP. cấp cho mang đến. Trong khi có thể thông số kỹ thuật qos trên Router ISP.

Cấu hình với rất nhiều luồng con đường đi:


Sử dụng chính sách aggregate

Bước 1: Tạo aggregate-police cùng với 320000 là băng thông, 8000 là tốc độ burst.

SW1(config)#mls qos aggregate-policeWeb-telnet320000 8000 exceed-action drop

Cách 2: Tạo 2 access-list, tạo ra 2 class-bản đồ gán với 2 access-các mục đó

SW1(config)#access-menu 100 permit tcp 192.168.1.0 0.0.0.255 192.168.20.6 0.0.0.0 eq 80

SW1(config)#access-danh sách 2 permit 192.168.2.0 0.0.0.255

SW1(config)#class-mapweb

SW1(config-cmap)#match access-group name 100

SW1(config-cmap)#exit

SW1(config)#class-maptelnet

SW1(config-cmap)#match access-group name 2

SW1(config-cmap)#exit

+ Bước 3: Tạo policy-maps AGGREGATE

SW1(config)#policy-bản đồ AGGREGATE

SW1(config-pmap)#class web

SW1(config-pmap-c)#police aggregateWeb-telnet

SW1(config-pmap-c)#exit

SW1(config-pmap)#class telnet

SW1(config-pmap-c)#police aggregateWeb-telnet

SW1(config-pmap-c)#exit

SW1(config-pmap)#exit

Cách 4: Gán service policy vào cổng đồ lí

SW1(config)#interface f0/1-2

SW1(config-if)#service-policy input đầu vào AGGREGATE

Vậy thì PC0 sẽ truy cập web cùng PC1 teđến hệ thống local, cùng với lượng đường dẫn thông thường vẫn thông số kỹ thuật là 3,2Mbps

Policing a Switched Virtual Interface:

Bước 1: Cấu hình tin tưởng vlan-based trên cổng thiết bị lí.

SW1(config-if-range)#mls qos vlan-based

SW1(config-if-range)#exit

Bước 2: Tạo access-danh sách, sinh sản 1 class-bản đồ tương xứng, tạo nên 1 class-bản đồ gán cùng với cổng đồ lí.

SW1(config)#access-danh sách 100 permit udp any any range 16384 32767

SW1(config)#class-bản đồ RTP

SW1(config-cmap)#match access-group 100

SW1(config-cmap)#exit

SW1(config)#class-map PORTS

SW1(config-cmap)#exit

Bước 3: Tạo 1 policy-map nhằm giới hạn đường truyền (child policy map), tạo thành 1 policy map (parent policy map) nhằm gán quý hiếm dscp, gán them child policy-map nghỉ ngơi trên

SW1(config)#policy-bản đồ PORT

SW1(config-pmap)#class PORTS

SW1(config-pmap-c)#police 256000 8000 exceed-action drop

SW1(config-pmap-c)#exit

SW1(config-pmap)#exit

SW1(config)#policy-bản đồ VLAN

SW1(config-pmap)#class RTP

SW1(config-pmap-c)#set dscp 46

SW1(config-pmap-c)#service-policy PORT

SW1(config-pmap-c)#exit

SW1(config-pmap)#exit

SW1(config)#int vlan 100

SW1(config-if)#service-policy input đầu vào VLAN

Dưới dây là 1 trong ví dụ khác: Đây là số đông vlan đang có và trải đời là cấp băng thông, đặt quý hiếm ip precedence đến từng loại dịch vụ. Ta vẫn cấu hình bên trên sw 3560

VLAN ID VLAN NAME BANDWIDTH PRECEDENCE

——————————————————————————–

10 IPMux 16 Mbps 5

đôi mươi Cameras 2 Mbps 7

30 Scadomain authority 6 Mbps 6


Cách 1: Khởi sản xuất qos

mls qos

Bước 2: Tạo policy map:

Ví dụ: policy-map bw6M (child policy map) nhằm giới hạn đường dẫn, policy-bản đồ vlan 30 (parent policy-map) để tại vị cực hiếm ip precedence

!

policy-map bw6M

mô tả tìm kiếm *************** VLAN 30 Scada ***************

class class-default

police 6000000 8000 exceed-action drop

policy-bản đồ VLAN30

class class-default

set precedence 6

service-policy bw6M

!

policy-bản đồ bw2M

description *************** VLAN đôi mươi Cameras ***************

class class-default

police 2000000 8000 exceed-action drop

policy-bản đồ VLAN20

class class-default

set precedence 7

service-policy bw2M

!

policy-maps bw16M

mô tả tìm kiếm *************** VLAN 10 IPMux ***************

class class-default

police 16000000 8000 exceed-action drop

policy-bản đồ VLAN10

class class-default

mix precedence 5

service-policy bw16M

Cách 3: Cấu hình trên cổng: access vlan với qos mang lại vlan

interface FastEthernet0/1

switchport mode access

mls qos vlan-based

!

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

mls qos vlan-based

!

!

interface FastEthernet0/2

switchport access vlan 20

switchport mode access

mls qos vlan-based

!

!

interface FastEthernet0/3

switchport access vlan 30

switchport mode access

mls qos vlan-based

!

!

Cách 4: Cấu hình trunking

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

mls qos vlan-based

Cách 5: Assign the policy maps khổng lồ the SVIs: Gán policy-bản đồ vào vlan

!

interface Vlan10

no ip address

service-policy input đầu vào VLAN10

!

interface Vlan20

no ip address

service-policy input đầu vào VLAN20

!

interface Vlan30

no ip address

service-policy input đầu vào VLAN30

!

Congestion Management:Quản lí tắc nghẽn

quý khách hàng hoàn toàn có thể ưu tiên lưu lượng bằng cách đặt các gói gồm DSCPhường hoặc CoS vào những hàng hóng khăng khăng với điều chỉnh ngưỡng mặt hàng đợi nhằm các gói có cường độ ưu tiên thấp hơn bị nockout bỏ

Ánh xạ giá trị cos hoặc dscp tới mặt hàng đợi (queue) và ngưỡng (threshold)

Theo mang định, những giá trị DSCP 0–39, 48–63 được ánh xạ tới queue 1 và threshold 1. Các giá trị DSCP. 40–47 được ánh xạ tới queue 2 với threshold 1.

Theo mặc định, giá trị CoS 0–4, 6 với 7 được ánh xạ tới queue 1 và threshold 1. Giá trị CoS 5 được ánh xạ cho tới queue 2 với threshold 1.

Queue: từ một đến 2.Threshold: 1 mang đến 3..

Gán nhị Xác Suất ngưỡng WTD mang đến (threshold 1 với 2) vào hàng chờ nhập. Mặc định, cả hai ngưỡng được đặt thành 100%.

Đối với ngưỡng Phần Trăm xác suất ngưỡng1, phạm vi từ là 1 mang đến 100. Tách từng cực hiếm bằng khoảng White.

Mỗi giá trị ngưỡng là tỷ lệ của tổng số bộ biểu thị sản phẩm ngóng được phân chia đến sản phẩm ngóng.

VD:

Switch(config)# mls qos srr-queue input đầu vào dscp-maps queue 1 threshold 1 0 1 2 3 4 5 6

Switch(config)# mls qos srr-queue input dscp-maps queue 1 threshold 2 20 21 22 23 24 25 26

Switch(config)# mls qos srr-queue input đầu vào threshold 1 50 70

lấy ví dụ như này cho biết thêm phương pháp ánh xạ quý hiếm DSCP 0 đến 6 nhằm lấy về ngóng 1 (queue) và cho ngưỡng 1 (threshold) với ngưỡng giảm 1/2. Nó ánh xạ những quý hiếm DSCPhường từ bỏ 20 đến 26 để du nhập hóng 1 với cho ngưỡng 2 với ngưỡng giảm 70%. Trong ví dụ này, những giá trị DSCPhường (0 đến 6) được gán ngưỡng WTD là 1/2 với đã bị nockout bỏ nhanh chóng hơn cực hiếm DSCP. (đôi mươi đến 26) được gán mang lại ngưỡng WTD là 70%.

Dường như hoàn toàn có thể ánh xạ quý giá cos

Switch(config)# mls qos srr-queue đầu vào cos-bản đồ queuequeue-idthresholdthreshold-id cos1…cos8

Shaped Round Robin (SRR):

SRR gồm 2 chế độ hoạt động

Shaped

Chỉ có sẵn trên mặt hàng hóng đi ra.

Hàng hóng nhận thấy 1 phần dự trữ 1 phần của một cổng đường dẫn với không thể nữa.

Shared

Có sẵn bên trên mặt hàng chờ vào với ra.

Hàng đợi được bảo vệ một trong những phần của cổng đường truyền.

Bandwidth Allocation for Input Queues (shared mod):Gắn đường dẫn vào sản phẩm chờ nguồn vào (queue)

SW1(config)#mls qos srr-queue input bandwidth 30 70

30% băng thông cho queue 1 với 70% đến queue 2

Bandwidth Allocation for Output Queues (shared mod):Gán băng thông đến sản phẩm đợi áp ra output.

SW1(config)#int gig 1/0/4

SW1(config-if)#tốc độ 1000

SW1(config-if)#srr-queue bandwidth nói qua 10 25 35 50

Determine the amount of bandwidth available to lớn each output queue on interface Gigabit Ethe1/0/4.

Xem thêm: Thẻ Rfid Là Gì ? Tính Năng Và Ưu Điểm Của Nó Trong Sản Xuất Tính Năng Và Ưu Điểm Của Nó Trong Sản Xuất

BW for Q1: * 1000 Mbps = 83.3 Mbps

BW for Q2: * 1000 Mbps = 208.3 Mbps

BW for Q3: * 1000 Mbps = 291.7 Mbps

BW for Q4: * 1000 Mbps = 416.7 Mbps

Bandwidth Allocation for Output Queues (Shaped Mode): Băng thông giới hạn

SW1(config)#int gig 1/0/5

SW1(config-if)#tốc độ 1000

SW1(config-if)#srr-queue bandwidth shape 30 0 0 0

Determine the amount of bandwidth limits applied to the output queues on interface Gigabit Ethe1/0/5.

BW Limit for Q1: 1/30 * 1000 Mbps = 33.3 Mbps

BW Limit for Q2: No limit applied

BW Limit for Q3: No limit applied

BW Limit for Q4: No limit applied

Example:

SW1(config)#int gig 1/0/6

SW1(config-if)#speed 1000

SW1(config-if)#srr-queue bandwidth nội dung 100 100 40 20

SW1(config-if)#srr-queue bandwidth shape 50 50 0 0

BW Limit for Q1 (Mbps): (1/50) * 1000 = trăng tròn Mbps

BW Limit for Q.2 (Mbps): (1/50) * 1000 = đôi mươi Mbps

Total Bandwidth (Mbps) = 20 + 20 + 640 + 320 = 1000 Mbps

Limiting Bandwidth on an Output đầu ra Interface:

SW1(config-if)#srr-queue bandwidth limit 85

The interface’s outbound bandwidth is limited lớn 85 percent of the interface speed